Skip to main content

References

Standards​

  1. NIST. FIPS 204: Module-Lattice-Based Digital Signature Standard (ML-DSA). August 2024.
  2. NIST. FIPS 203: Module-Lattice-Based Key-Encapsulation Mechanism Standard (ML-KEM). August 2024.
  3. NIST. IR 8547: Transition to Post-Quantum Cryptography Standards. 2024.
  4. E. Rescorla. RFC 8446: The Transport Layer Security (TLS) Protocol Version 1.3. 2018.
  5. P. Wouters et al. RFC 7250: Using Raw Public Keys in TLS and DTLS. 2014.
  6. X25519MLKEM768 and MLKEM768 hybrid and post-quantum key agreement for TLS 1.3, IETF drafts.
  7. M. Palatinus et al. BIP 39: Mnemonic code for generating deterministic keys.
  8. BIP 199: Hashed Time-Locked Contract transactions.

Cryptography​

  1. P. W. Shor. Polynomial-time algorithms for prime factorization and discrete logarithms on a quantum computer. SIAM J. Computing, 1997.
  2. L. K. Grover. A fast quantum mechanical algorithm for database search. STOC 1996.
  3. L. Ducas et al. CRYSTALS-Dilithium: A Lattice-Based Digital Signature Scheme. TCHES 2018.
  4. J. Bos et al. CRYSTALS-Kyber: a CCA-secure module-lattice-based KEM. EuroS&P 2018.
  5. E. Ben-Sasson, I. Bentov, Y. Horesh, M. Riabzev. Scalable, transparent, and post-quantum secure computational integrity. 2018.
  6. StarkWare. ethSTARK Documentation. 2021.
  7. L. Grassi, D. Khovratovich, M. Schofnegger. Poseidon2: A Faster Version of the Poseidon Hash Function. AFRICACRYPT 2023.
  8. E. Ben-Sasson et al. Zerocash: Decentralized Anonymous Payments from Bitcoin. IEEE S&P 2014.
  9. D. Hopwood et al. Zcash Protocol Specification.
  10. J.-P. Aumasson et al. BLAKE2: simpler, smaller, fast as MD5. 2013.
  11. D. J. Bernstein. ChaCha, a variant of Salsa20. 2008; Y. Nir, A. Langley. RFC 8439: ChaCha20 and Poly1305.
  12. A. Biryukov, D. Dinu, D. Khovratovich. Argon2: the memory-hard function for password hashing. RFC 9106, 2021.

Consensus and economics​

  1. S. Nakamoto. Bitcoin: A Peer-to-Peer Electronic Cash System. 2008.
  2. tevador et al. RandomX: proof of work algorithm based on random code execution. 2019.
  3. zawy12. LWMA difficulty algorithm. 2018.
  4. I. Eyal, E. G. Sirer. Majority is not enough: Bitcoin mining is vulnerable. FC 2014.
  5. A. Gervais et al. On the Security and Performance of Proof of Work Blockchains. CCS 2016.

Agents and payments​

  1. Model Context Protocol specification. modelcontextprotocol.io, 2024.
  2. J. Poon, T. Dryja. The Bitcoin Lightning Network: Scalable Off-Chain Instant Payments. 2016.
  3. R. Fielding et al. RFC 9110: HTTP Semantics — status code 402 Payment Required.
  4. T. Nolan. Alt chains and atomic transfers. 2013.

Software​

  1. Parity Technologies. Polkadot SDK (Substrate, FRAME), release stable2606.
  2. Parity Technologies. PolkaVM and revive (resolc, pallet-revive).
  3. Polygon Labs and contributors. Plonky3.
  4. RustCrypto. ml-dsa, ml-kem, chacha20poly1305, argon2.
  5. AWS. AWS-LC and aws-lc-rs.
  6. paulmillr. noble-post-quantum.
  7. XMRig developers. XMRig.

The source code of Tesserax: https://github.com/Tesserax-foundation/tesserax.